Welcome Guest! To enable all features please Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Offline woozle  
#1 Posted : Friday, June 29, 2012 7:44:42 AM(UTC)
woozle
Rank: Advanced Member

Joined: 2/2/2009(UTC)
Posts: 42
Location: London, UK

Any ideas where to get older versions of libspotify from?

I've got the spotify plugin compiled and working, but the only version I could find of libspotify.dll is a newer version, which AVG keeps detecting as a virus. I'm pretty sure it's a false positive, and so I'll follow it up with them, but in the meantime, if you've any ideas about where to get the version you recommend, that would help :-)

Thanks,
Rob
Offline Scott  
#2 Posted : Friday, June 29, 2012 8:22:29 AM(UTC)
Scott
Rank: Administration

Joined: 1/25/2009(UTC)
Posts: 2,341
Location: Orlando, FL, USA

Originally Posted by: woozle Go to Quoted Post
Any ideas where to get older versions of libspotify from?

I've got the spotify plugin compiled and working, but the only version I could find of libspotify.dll is a newer version, which AVG keeps detecting as a virus. I'm pretty sure it's a false positive, and so I'll follow it up with them, but in the meantime, if you've any ideas about where to get the version you recommend, that would help :-)

Thanks,
Rob

Rob, good to see ya! Smile

Which version are you looking for? So far, the URL's to libspotify.dll all follow the same convention, so if you have one just swap out the version numbers and you'll be good to go.

I've got a direct link on the Spotify for Jamcast page @ Codeplex to 11.1.60 (for this very reason) if that's the one you were looking for:

https://developer.spotif...1.1.60-win32-release.zip

Thanks!
Scott
Jamcast Developer
Support Page: http://getjamcast.com/Support.aspx
Offline woozle  
#3 Posted : Friday, June 29, 2012 11:01:09 AM(UTC)
woozle
Rank: Advanced Member

Joined: 2/2/2009(UTC)
Posts: 42
Location: London, UK

Um, good question... I did download that version originally, but couldn't get it working for some reason, can't remember why now.
I got really confused with too many windows open for different downloads of different things to bring it all together, and can't remember now what I ended up doing!

I think in one of the other threads you were referring to a different version - something about 1.45, I vaguely remember...

I'll have to look at it again.
Offline Scott  
#4 Posted : Friday, June 29, 2012 2:26:14 PM(UTC)
Scott
Rank: Administration

Joined: 1/25/2009(UTC)
Posts: 2,341
Location: Orlando, FL, USA

Originally Posted by: woozle Go to Quoted Post
Um, good question... I did download that version originally, but couldn't get it working for some reason, can't remember why now.
I got really confused with too many windows open for different downloads of different things to bring it all together, and can't remember now what I ended up doing!

I think in one of the other threads you were referring to a different version - something about 1.45, I vaguely remember...

I'll have to look at it again.

The confusing part is that libspotify.NET is on version 3.0.0.0, which works with libspotify 12.1.45. But the current version of libspotify is 12.1.51, and the plugin for Jamcast needs libspotify.NET 2.0 which uses version libspotify 11.1.60... Blink

OK, so here is what you need w/ download links:

Spotify Plugin for Jamcast v1.1
http://spotifyforjamcast....com/releases/view/87621

libspotify.NET v2.0 (x86)
http://libspotifydotnet.....com/releases/view/87620

libspotify DLL 11.1.60
https://developer.spotif...1.1.60-win32-release.zip

I assume you already built the most current release of the plugin, so just download those other 2 DLL's and you should be good. Let me know.

Thanks!
Scott
Jamcast Developer
Support Page: http://getjamcast.com/Support.aspx
Offline woozle  
#5 Posted : Sunday, July 1, 2012 3:20:29 AM(UTC)
woozle
Rank: Advanced Member

Joined: 2/2/2009(UTC)
Posts: 42
Location: London, UK

I'd made a couple of mistakes previously, but the main one was that I'd used libspotify.net v3.0, thinking that it was newer so it should be alright! And hadn't noticed there was a link to 2.0 on the same page. I guess it's too easy to assume something's going to be backwards compatible!

Anyway, fixed now, thanks :-)

Rob
Offline Scott  
#6 Posted : Tuesday, July 3, 2012 11:55:50 AM(UTC)
Scott
Rank: Administration

Joined: 1/25/2009(UTC)
Posts: 2,341
Location: Orlando, FL, USA

Originally Posted by: woozle Go to Quoted Post
I'd made a couple of mistakes previously, but the main one was that I'd used libspotify.net v3.0, thinking that it was newer so it should be alright! And hadn't noticed there was a link to 2.0 on the same page. I guess it's too easy to assume something's going to be backwards compatible!

Anyway, fixed now, thanks :-)

Rob

Hey Rob,

Great, so everything is working OK then?

I probably need to update the plugin to start using libspotify.NET 3.0.0.0, and also using the latest version of libspotify. It does get confusing...

Thanks!
Scott
Jamcast Developer
Support Page: http://getjamcast.com/Support.aspx
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.088 seconds.